Zdiagnozowane problemy po migracji danych w TFI Allianz i zmianie dostawcy PPK API w programie Symfonia ERP Kadry i Płace

Edyta Tudek
Edyta Tudek
  • Zaktualizowano

26-27 października 2024, TFI Allianz przeprowadziło wewnętrzną migrację danych swoich klientów. W tym czasie komunikacja z TFI Allianz przez pliki lub API mogła być niedostępna z przyczyn technicznych leżących po stronie Allianz. Obsługa wymiany danych po migracji w systemach TFI Allianz wymaga aktualizacji systemu Symfonia ERP Kadry i Płace do najnowszej wersji 2024.h, w której został zmieniony mechanizm API PPK dla TFI Allianz. 

Pierwsze otworzenie okna Zarządzanie PPK w wersji 2024.h uruchamia mechanizm automatycznej zmiany dostawcy API. Zmiana PPK API są widoczne w programie w 3 obszarach:

1. W oknie Ustawienia Komunikacja PPK Połączenie zewnętrzne przez API → Wybór API powinna być pozycja Allianz PPK (fundusz Allianz SFIO PPK – d. Aviva SFIO PPK), która zastąpiła poprzednie API o nazwie Allianz PPK

2. W danych kadrowych firmy w zestawie Pracowniczy Plan Kapitałowy (PPK) w elemencie Umowa o zarządzanie PPK powinna być dodana nowa wartość z datą zmiany dostawcy, tj. pierwszego otworzenia okna Zarządzanie PPK z nową wartością w pozycji Nazwa instytucji - AVIVA TFI S.A. oraz nowym numerem umowy w pozycji Nr umowy PPK.

3. W danych kadrowych pracowników będących uczestnikami PPK w zestawie Pracowniczy Plan Kapitałowy (PPK) w elemencie Dane w instytucji powinna być dodana nowa wartość z datą zmiany dostawcy, tj. pierwszego otworzenia okna Zarządzanie PPK z nową wartością w pozycji Nr konta w instytucji

W ciągu ostatnich kilku dni otrzymaliśmy zgłoszenia od naszych użytkowników, że nie w każdej firmie automatyczna migracja na nowego dostawcę PPK API powiodła się. Pojawiły się inne problemy techniczne dotyczące komunikacji z TFI Allianz, które mogły zaburzyć pobieranie danych pracowników z z instytucji, a w konsekwencji błędy podczas próby generowania wpłat PPK. 

Zdiagnozowane problemy przy próbie generowania wpłat PPK do TFI Allianz za pośrednictwem API Allianz PPK (fundusz Allianz SFIO PPK – d. Aviva SFIO PPK).

I. Przy próbie wygenerowania wpłat PPK pojawia się komunikat o błędach dla pracowników: Employee has no PPK contract

Przyczyna:

Brak aktualizacji danych pracowników po zmianie dostawcy PPK API, nowe dane pracowników nie pobrały się z instytucji. W programie brak nowej wartości w elemencie Dane w instytucji.

Rozwiązanie:

  • Zrób kopię bazy przed wprowadzeniem zmian.
  • U pracowników, którzy nie mają pobranych nowych danych z instytucji wprowadź wczorajszą datę w w elemencie Dane w instytucji i zapisz zmiany. Punktem odniesienia jest dzień, w którym będziesz dokonywał tych zmian. Jeśli rozwiązanie zastosujesz 15.11.2024, to wartość kadrową zamknij z datą 2024-11-14.
  • Przejdź do okna Zarządzanie PPK i pobierz dane z instytucji przyciskiem Importuj dane.
  • powinien pojawić się komunikat o zaimportowaniu numeru PPK:
  • W danych kadrowych pracownika powinny dodać się nowe Dane w instytucji.
  • Możesz już wygenerować wpłaty.

II. Przy próbie wygenerowania wpłat PPK dla pracowników, którzy zakończyli zatrudnienie pokazuje się komunikat: Uczestnik nie jest zarejestrowany

Przyczyna:

Brak aktualizacji danych pracowników po zmianie dostawcy PPK API, nowe dane pracowników nie pobrały się z instytucji. W programie brak nowej wartości w elemencie Dane w instytucji.

Rozwiązanie:

  1. Wykonaj kopię bezpieczeństwa bazy danych.
  2. Zamknij program Symfonia ERP Kadry i Płace 2024.h lub nowszą.
  3. Pobierz załączony plik dla wersji 2024 h-k: PPKFindEmployee.zip i rozpakuj go, jest on zabezpieczony hasłem - hasło do pliku: KIP2024. Dla wersji 2025 i nowszych: PPKFindEmployee 1.zip
  4. Po rozpakowaniu pliku będzie dostępny plik PPKFindEmployee.dll, który skopiuj do folderu instalacyjnego programu w wersji 2024.h lub nowszej do podkatalogu Dodatki.
  5. Uruchom program Symfonia ERP Kadry i Płace i zaloguj się do bazy.
  6. W programie pojawi się nowa opcja w menu: Dodatki  Symfonia  PPK wyszukaj pracownika
  7. Wybierz tę opcję PPK wyszukaj pracownika.
  8. W wywołanym oknie wybierz przycisk Wyszukaj pracownika i wskaż pracownika/pracowników, u których w oknie Zarządzanie PPK był błąd Uczestnik nie jest zarejestrowany.
  9. Po zatwierdzeniu wybranych osób system wyszuka pracownika w instytucji i pobierze dane do pozycji Nr konta w instytucji w elemencie  Dane w instytucji.
  10. Po tej operacji możesz wygenerować wpłaty PPK do instytucji.

III. Przy próbie wygenerowania wpłat PPK dla pracowników pokazuje się komunikat: Nieprawidłowy 'Nr konta w instytucji'

Przyczyna:

Brak aktualizacji danych pracowników po zmianie dostawcy PPK API, nowe dane pracowników nie pobrały się z instytucji. W programie brak nowej wartości w elemencie Dane w instytucji.

Rozwiązanie:

Zaimportować dane z instytucji zgodnie z rozwiązaniem dla problemu nr I. 

  • Zrób kopię bazy przed wprowadzeniem zmian.
  • U pracowników, którzy nie mają pobranych nowych danych z instytucji wprowadź wczorajszą datę w w elemencie Dane w instytucji i zapisz zmiany. Punktem odniesienia jest dzień, w którym będziesz dokonywał tych zmian. Jeśli rozwiązanie zastosujesz 15.11.2024, to wartość kadrową zamknij z datą 2024-11-14.
  • Przejdź do okna Zarządzanie PPK i pobierz dane z instytucji przyciskiem Importuj dane.
  • powinien pojawić się komunikat o zaimportowaniu numeru PPK:
  • W danych kadrowych pracownika powinny dodać się nowe Dane w instytucji.
  • Możesz już wygenerować wpłaty.

 

Czy ten artykuł był pomocny?

Liczba użytkowników, którzy uważają ten artykuł za przydatny: 0 z 0